Requirements

You can enjoy OpenScienceMap on most devices running Android 2.3 and above. OpenScienceMap makes heavy usage of OpenGL. Some devices have reported issues (such as some HTC models). If you experience problems with OpenScienceMap, please let us know!

OpenScienceMap is a gentle app. It runs fluently even on older devices and does not consume too much resources.

Make sure you allow apps not coming via Google’s PlayStore:

  • 1. Open the “Settings” menu
  • 2. Click “Applications”
  • 3. Tick “Unkown Sources”